R cannot be resolved...Android高低版本兼容性修正2014-10-14 17:32:57

( 1人已投票,[高质量] )
分享:
31.3K

对于下载的开发包加入项目工程后经常会出现类似“R cannot be resolved...”类错误

那么你可以看一下AndroidManifest中的版本说明,version,与当前版本比较如果低了,那么下面的方法可以解决

android低版本工程(如1.5)放到高版本环境中(如2.2)解决方法如下:
1。 如果不修改android sdk版本,则使用project-> clean 命令作用于工程即可。

(该处理方式只是在高版本中兼容了低版本工程,未真正意义上的升级)(小数情况还是不行就看下一步)
2。 修改android sdk版本,则需要以下几个步骤:
      1) 修改SDK
            选择工程(右健),build path --> configure build path ---> library 删除引用的低版本SDK(remove),
            然后add External JARs,选择高版本SDK,OK,保存(例如8 对应2.2版本)
       2) 修改classpath文件(工程文件包中具有.classpath文件,以txt打开)
            该文件可能存在该项: <classpathentry kind="lib"   path ="你所指定的高版本的地址" (这句不要了)
            把它替换为<classpathentry kind="con" path="com.android.ide.eclipse.adt.ANDROID_FRAMEWORK" />
       3) 修改AndroidManifest.xml
            在AndroidManifest.xml文件中,application标签后添加<uses-sdk android:minSdkVersion="3"></uses-sdk>  

           (注意,里面可能有多个Version,有的话都得改)
       4) 修改default.properties很重要
             该文件最后一行(前面没用#的,#号是注释)target=android-3 改成 target=android-8,保存。 最后重新Clean一次工程.(版本的问题就应该解决了,通过测试)
       再看看你的工程和新建的android 2.2的工程结构就一样了。






头像

snowcoal
  • Android
  • 高低版本兼容
  • 版本号修改

收藏到我的私密空间

标题:R cannot be resolved...Android高低版本兼容性修正

作者:花花世界

你暂未登录,请登录后才可收藏至您的私密空间 确认取消
雪炭网

键盘操作 更便捷 -雪炭网雪中送炭-乐趣无限